52456a5f297140b1f45c6f7a95f34abd9976aaa0
[opentox-client] / opentox-client.gemspec
1 # -*- encoding: utf-8 -*-
2 $:.push File.expand_path("../lib", __FILE__)
3
4 Gem::Specification.new do |s|
5   s.name        = "opentox-client"
6   s.version     = "0.0.1pre"
7   s.authors     = ["Christoph Helma, Martin Guetlein, Andreas Maunz, Micha Rautenberg, David Vorgrimmler"]
8   s.email       = ["helma@in-silico.ch"]
9   s.homepage    = "http://github.com/opentox/opentox-client"
10   s.summary     = %q{Ruby wrapper for the OpenTox REST API}
11   s.description = %q{Ruby wrapper for the OpenTox REST API (http://www.opentox.org)}
12   s.license     = 'GPL-3'
13
14   s.rubyforge_project = "opentox-client"
15
16   s.files         = `git ls-files`.split("\n")
17   s.test_files    = `git ls-files -- {test,spec,features}/*`.split("\n")
18   s.executables   = `git ls-files -- bin/*`.split("\n").map{ |f| File.basename(f) }
19   s.require_paths = ["lib"]
20
21   # specify any dependencies here; for example:
22   s.add_runtime_dependency "bundler"
23   s.add_runtime_dependency "rest-client"
24   s.add_runtime_dependency "rdf"
25   s.add_runtime_dependency "rdf-raptor"
26   s.add_runtime_dependency "open4"
27   
28   # external requirements
29   ["libraptor-dev"].each{|r| s.requirements << r}
30   s.post_install_message = "Please check the version of your libraptor library, if installation of rdf.rb fails"
31 end