summaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
authorChristoph Helma <helma@in-silico.ch>2021-03-08 17:41:26 +0100
committerChristoph Helma <helma@in-silico.ch>2021-03-08 17:41:26 +0100
commit08e5768e9a446db8ab95152d2e9403a0e635ec63 (patch)
tree6f4486c6bfd84b69febcb9d3a4d9de8fee1b1a26 /shell.nix
parenta29eb3e38414cd252850c9c4fb356f8b2bef6fb4 (diff)
cdk predictions fixed
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix36
1 files changed, 1 insertions, 35 deletions
diff --git a/shell.nix b/shell.nix
index 3baa358..dc582fb 100644
--- a/shell.nix
+++ b/shell.nix
@@ -1,42 +1,8 @@
with import <nixpkgs> { };
let
R-packages = rWrapper.override { packages = with rPackages; [ ggplot2 caret ]; };
- openbabel = stdenv.mkDerivation {
-
- name = "openbabel-ruby";
-
- src = fetchurl {
- url = "https://github.com/openbabel/openbabel/releases/download/openbabel-3-1-1/openbabel-3.1.1-source.tar.bz2";
- sha256 = "puyDgdWeoypLJByLH715mstSvpSrZM29clBvtOInDmg=";
- };
-
- #outputs = [ "lib" ];
-
- buildInputs = [
- # openbabel
- cmake
- ruby
- swig
- boost
- zlib
- libxml2
- cairo
- eigen
- pkg-config
- pcre
- ];
-
- configurePhase = ''
- cmake . -DWITH_MAEPARSER=OFF -DWITH_JSON=OFF -DBUILD_GUI=OFF -DENABLE_TESTS=OFF -DRUN_SWIG=ON -DBINDINGS_ONLY=ON -DRUBY_BINDINGS=ON -DMINIMAL_BUILD=ON -DOPTIMIZE_NATIVE=ON -DCMAKE_INSTALL_PREFIX=$out -DCMAKE_INSTALL_RPATH:STRING=$out/lib
- '';
-
- buildPhase = ''
- make -j12
- '';
-
- };
in mkShell {
- name = "mutagenicity-paper";
+ name = "lazar";
buildInputs = [
git
R-packages