summaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
authorChristoph Helma <helma@in-silico.ch>2021-02-06 20:21:58 +0100
committerChristoph Helma <helma@in-silico.ch>2021-02-06 20:21:58 +0100
commit771a2381ae0fd5e352f23d7223baeb26e8bb4e02 (patch)
tree1a7182a83ec15b9d7a69e5508c8d3b2bfa5983df /shell.nix
parent241f997c3a1a6a38fa47070f5efbd23852cc432b (diff)
svm validation, tensorflow mp2d pa predictions, r results removed, cleanup
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix11
1 files changed, 6 insertions, 5 deletions
diff --git a/shell.nix b/shell.nix
index d5d23ee..0d0a588 100644
--- a/shell.nix
+++ b/shell.nix
@@ -1,9 +1,10 @@
-#with import <nixpkgs> { };
-with import (fetchTarball "https://github.com/NixOS/nixpkgs/archive/27212188ee8072ee79a4633e95fb5c731d40e1c0.tar.gz") { };
+with import <nixpkgs> { };
+#https://github.com/NixOS/nixpkgs/archive/nixos-unstable.tar.gz
+#with import (fetchTarball "https://github.com/NixOS/nixpkgs/archive/27212188ee8072ee79a4633e95fb5c731d40e1c0.tar.gz") { };
let
R-packages = rWrapper.override { packages = with rPackages; [ ggplot2 Rtsne ]; };
gems = pkgs.bundlerEnv { name = "mutagenicity"; gemdir = ./.; };
- #lazar-gems = pkgs.bundlerEnv { name = "lazar"; gemdir = ./../lazar; };
+ lazar-gems = pkgs.bundlerEnv { name = "lazar"; gemdir = ./../lazar; };
latex-authblk = texlive.combine { inherit (texlive) scheme-medium preprint; };
in pkgs.mkShell {
@@ -14,11 +15,11 @@ in pkgs.mkShell {
git
latex-authblk
fontconfig
- haskellPackages.pandoc-placetable
+ #haskellPackages.pandoc-placetable
haskellPackages.pandoc-crossref
haskellPackages.pandoc-citeproc
R-packages
- #lazar-gems
+ lazar-gems
gems
gems.wrappedRuby
];